Subscribed unsubscribe Subscribe Subscribe

Python 2.6.1 + f2py (numpy-1.2.1) で生成されたラッパーが動作しない件

python numpy f2py scipy

http://projects.scipy.org/numpy/ticket/964

more argument specifiers than keyword list entries

などとぬかしやがります。ってか下位互換性をキープしてない Python も悪いし、変なフォーマット文字列を PyArg_ParseTupleAndKeywords() に渡している f2py も悪い。(両成敗的な意味ではなく)

Numpy の trunk でも Python 2.6.2 でも直ってるそうなので別にいいんだけど、かなり時間が無駄になったのでメモという事で。